Akses PC Secara Remote Dengan TeamViewer

Rasa-rasanya, sekarang ini segala pekerjaan bisa dilakukan secara online, termasuk urusan perbaikan PC.

Teringat pada jaman dahulu (macam judul animasi) saat saya masih menjadi pria panggilan servis komputer, saya datang ke rumah atau kantor yang memerlukan jasa perbaikan komputer. Memang sekarangpun masih menerima panggilan servis, walaupun tidak full time.

Setelah internet merajalela hingga era smartphone seperti sekarang, perbaikan komputer tidak mesti mendatangi rumah si empunya PC secara langsung. Asalkan PC nya terhubung dengan internet, saya bisa melakukan perbaikan secara remote. Masalah biaya servis tinggal transfer via online juga. Praktis kan?

Software yang saya pakai untuk kegiatan remote ini adalah TeamViewer. Keunggulan utama dari TeamViewer adalah tidak perlu melakukan pengaturan proxy, router atau firewall. Cukup install TeamViewer di PC asal dan PC tujuan, masukkan ID dan Password PC tujuan, dan langsung bisa tersambung. Berikut langkah-langkah nya:

  1. Download TeamViewer sesuai OS yang kisanak gunakan
  2. Install seperti biasa
  3. Buka TeamViewer di PC tujuan dan PC asal
  4. Masukkan ID dan Password PC tujuan lalu klik Connect to partner
  5. Selesai

1Setelah langkah diatas, tampilan PC tujuan akan tampil di PC asal, seperti bekerja langsung di PC tujuan.

Selain tersedia untuk versi PC, TeamViewer juga tersedia untuk Android, sehingga kisanak bisa mengakses PC melalui smartphone Android, sepanjang koneksi internet smartphone kisanak mencukupi untuk kegiatan remote. Untuk penggunaan TeamViewer versi Android akan saya jelaskan pada artikel mendatang.

Tetaplah di padepokan Go….!!!!BLOG.

[Mikrotik] Memisahkan Bandwidth Gaming dan Browsing (Bag. 2 dari 2)

Sebelumnya Part 1, memisahkan traffic PING, DNS dan Game Online

Selamat malam kisanak.

Pada bagian terakhir ini kita tinggal memisahkan traffic browsing dengan menggunakan simple queue. Tapi sebelumnya kita kilas balik dulu artikel pada part 1 yaitu:

  1. Membuat mangle traffic PING (port ICMP) dan mark connection
  2. Membuat mangle traffic DNS (TCP Port 53) dan mark connection
  3. Mark Packet ICMP dan DNS berdasarkan mark connection
  4. Membuat simple queue traffic ICMP dan DNS berdasarkan Mark Packet.
  5. Membuat mangle port TCP dan UDP beberapa game populer dan mark connection
  6. Mark Packet port game populer berdasarkan mark connectionnya
  7. Membuat simpe queue traffic game berdasarkan mark packet.

Sekarang kita buat simple queue untuk traffic browsing. Karena traffic ICMP, DNS dan game sudah kita buat mangle, maka untuk traffic browsing tidak usah membuat mangle lagi, jadi kita anggap diluar traffic ICMP, DNS dan game adalah traffic browsing.

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=384k/1800k name=\
“C. Client Browsing” packet-marks=”” parent=none priority=7 queue=\
default-small/default-small target-addresses=192.168.1.0/24 total-queue=\
default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=0/768k name=PC1 \
packet-marks=”” parent=”C. Client Browsing” priority=8 queue=\
default-small/default-small target-addresses=192.168.1.2/32 total-queue=\
default-small

..dan seterusnya sesuaikan dengan jumlah client

26Seperti terlihat pada gambar, untuk simple queue traffic browsing saya buat limit di 1.8Mbps, sedangkan limit per client di 768kbps tanpa burst. Karena di warnet saya lebih banyak main game online, makanya untuk traffic browsing saya buat seperti diatas, karena dari 6 client, paling banyak yang browsing maksimal hanya 3 client.

Dari total bandwidth 3Mbps (aktual 2.7Mpbs) diatas kertas memang masih banyak sisa bandwidth tidak terpakai. Perhitungan bandwidth kasarnya sebagai berikut:

Game online rata-rata 100kbps x 6 = 600kbps

Browsing = 1800kbps

Total dalam posisi client semua terpakai = 2.4Mbps

Masih ada sisa ­± 300kbps yang berguna untuk traffic DNS dan ICMP, atau untuk jaga-jaga bila koneksi sedang drop (maklum koneksi internet di kampung).

Catatan akhir:

Kisanak harus sering-sering monitor traffic game dengan Torch, dan tambahkan port pada mangle karena bisa saja port yang digunakan pada game tertentu berubah, atau ada penambahan game baru dengan port berbeda. Bila tidak diperhatikan sudah pasti traffic game tersebut akan lari ke traffic browsing, dan nantinya akan ter-limit. Hasilnya game akan lag.

Demikian akhir dari artikel berseri kali ini. Saran, kritik, caci maki dan transferannya selalu saya tunggu di pojok komentar.

[Mikrotik] Memisahkan Bandwidth Gaming dan Browsing (Bag. 1 dari 2)

Bila kemarin kisanak sudah mengetahui pengaturan dasar Simple Queue, sekarang kita coba pengaturan Simple Queue lanjutan.

Pada Simple Queue dasar, semua koneksi-baik browsing atau gaming-disatukan dalam satu limit. Artinya misalkan satu client sedang buka Youtube sambil main game PointBlank (kok ya kemaruk yah makan bandwidthnya wkwk), sudah pasti koneksi game PointBlank akan terganggu, karena bandwidth sudah habis oleh YouTube. Sekarang kita coba memisahkan koneksi game dan browsing, dengan prioritas lebih kepada traffic game online, traffic PING, dan traffic DNS.

Bila pada artikel Mikrotik yang lalu saya selalu memberikan contoh gambar, sekarang saya akan memberikan lebih banyak contoh script untuk mempermudah saya dan kisanak juga (tinggal copy paste kan enak yah).

Langkah 1.a: Prioritas Traffic PING (ICMP) dan DNS

Dasar pemisahan traffic secara garis besar dilakukan dengan:

  1. Membuat mangle Mark Connection untuk traffic PING (protokol ICMP)
  2. Membuat mangle Mark Connection untuk traffic DNS (protokol TCP port 53)
  3. Membuat mangle Mark Packet untuk traffic PING dan DNS
  4. Membuat Simple Queue untuk traffic PING dan DNS

Tiga mangle diatas berkhasiat untuk mem-prioritaskan PING dan traffic DNS, sehingga saat bermain game online, PING akan selalu menghijau, alias latency nya rendah. Dan saat browsing, koneksi ke DNS Server tidak mendapat pembatasan sehingga browser akan menemukan alamat web dengan lebih cepat.

Script Langkah 1.a :

/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no in-interface=LAN \
new-connection-mark=icmp_conn passthrough=yes protocol=icmp
add action=change-dscp chain=prerouting connection-mark=icmp_conn disabled=no \
new-dscp=1 passthrough=yes
add action=mark-packet chain=prerouting connection-mark=icmp_conn disabled=no \
new-packet-mark=icmp_pkt passthrough=no
add action=mark-connection chain=prerouting disabled=no dst-port=53 \
in-interface=LAN new-connection-mark=dns_conn passthrough=yes protocol=\
tcp
add action=change-dscp chain=prerouting connection-mark=dns_conn disabled=no \
new-dscp=1 passthrough=yes
add action=mark-packet chain=prerouting connection-mark=dns_conn disabled=no \
new-packet-mark=dns_pkt passthrough=no

Langkah 1.b: Membuat Queue Type metode PFIFO (Packet First In First Out)

Script Langkah 1.b:

/queue type

add kind=pfifo name=critical pfifo-limit=64

Langkah 1.c: Membuat Simple Queue traffic ICMP dan DNS

Script Langkah 1.c:

Catatan: Untuk Target-addresses sesuaikan dengan IP Address client kisanak.

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=100M/100M name=\
“A. Critical” packet-marks=icmp_pkt,dns_pkt parent=none priority=5 queue=\
critical/critical target-addresses=192.168.1.0/24 total-queue=\
default-small

Langkah 2.a: Prioritas Traffic Game Online Populer

Dasar pemisahan traffic game online secara garis besar dilakukan dengan:

  1. Membuat mangle Mark Connection untuk traffic TCP game online
  2. Membuat mangle Mark Connection untuk traffic UDP game online
  3. Membuat mangle Mark Packet untuk traffic TCP dan UDP game online
  4. Membuat Simple Queue untuk traffic TCP dan UDP game online

Script Langkah 2.a:

Catatan: Untuk in-interface sesuaikan dengan nama interface yang menghadap LAN kisanak.

/ip firewall mangle

add action=mark-connection chain=prerouting comment=PointBlank disabled=no \
dst-port=39190-39200 in-interface=LAN new-connection-mark=game_online \
passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=DOTA2 disabled=no \
dst-port=27000-27150,9100-9200,8230-8250,8110-8120 in-interface=LAN \
new-connection-mark=game_online passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Ayodance disabled=no \
dst-port=18900-18910 in-interface=LAN new-connection-mark=game_online \
passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=CS disabled=no dst-port=\
47611,8000-8010,36567 in-interface=LAN new-connection-mark=game_online \
passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Lost Saga” disabled=no \
dst-port=14000-14010 in-interface=LAN new-connection-mark=game_online \
passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”PointBlank UDP” \
disabled=no dst-port=40000-40010 in-interface=LAN new-connection-mark=\
game_online passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=”Lost Saga UDP” disabled=\
no dst-port=14000-14010 in-interface=LAN new-connection-mark=game_online \
passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=”DOTA2 UDP” disabled=no \
dst-port=27000-27150,3478-4380,28010-28200,39000 in-interface=LAN \
new-connection-mark=game_online passthrough=yes protocol=udp
add action=mark-packet chain=prerouting connection-mark=game_online disabled=\
no new-packet-mark=game_online passthrough=no

Script diatas berkhasiat untuk menandai paket data melalui port TCP/UDP beberapa game online populer

Langkah 2.b: Membuat Simple Queue Traffic Game Online

Script Langkah 2.b:

Catatan: Untuk Target-addresses sesuaikan dengan IP Address client kisanak.

/queue simple

add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=100M/100M name=\
“B. Game Online” packet-marks=game_online parent=none priority=6 queue=\
default-small/default-small target-addresses=192.168.1.0/24 total-queue=\
default-small

Dengan dua langkah diatas, maka traffic PING, DNS, dan Game Online dipisahkan dengan limit queue 100Mbps.

Limit queue 100Mbps ini sebenarnya hanya sekedar membuat limit yang tinggi untuk traffic PING, DNS dan Game Online. Bisa saja dibuat limit queue=unlimited, tapi sepengetahuan saya, bila dibuat unlimited nantinya traffic tidak terbaca di grafik traffic Winbox. cmiiw.

Berikut contoh gambar sesuai dengan script yang dibuat diatas:

25

Klik untuk memperbesar

Pada artikel selanjutnya kita akan bahas memisahkan traffic browsingnya. Jangan kemana-mana, tetap di Padepokan Go…..!!!!BLOG yang tercinta ini.

Simple Queue Mikrotik RouterOS

Dalam dunia bandwidth management Mikrotik, simple queue adalah fitur termudah dan ter-sederhana.

Seperti lazimnya bandwidth management, tujuan akhirnya adalah sudah pasti mengelola bandwidth yang kita miliki supaya tersalurkan kepada client yang membutuhkan secara adil dan merata. Coba bayangkan misalnya kisanak punya warnet dengan 10 client dan bandwidth 3Mbps. Apabila bandwidth tidak dikelola dengan baik, bisa-bisa bila ada satu client yang maniak download atau maniak JAV   Youtuber, semua bandwidth akan digunakan oleh satu client tersebut, sedangkan sisanya hanya bisa meringis karena koneksi internetnya lambat selambat siput yang sedang stroke.

Simple Queue pada Mikrotik RouterOS hadir sebagai solusi tercepat untuk menjatah bandwidth pada masing-masing client, dan juga settingnya terbilang sederhana, karena kisanak hanya perlu mengisi kolom target IP Address yang hendak di-limit, serta isi Max Limit untuk Download dan Upload, selesai! Bila perlu bisa juga mengatur Burst Limit yang akan saya jelaskan juga pada artikel kali ini.

Alat-alat yang dibutuhkan:

  1. Mikrotik RouterOS (versi 2 keatas) yang terpasang pada PC yang bertindak sebagai gateway. Lebih jelasnya bisa dilihat pada artikel lalu di padepokan ini.
  2. Winbox sebagai interface grafis ke Mikrotik RouterOS.

Langkah Kerja:

  1. Saya asumsikan Mikrotik RouterOS sudah terpasang dengan baik, dan bisa diakses dengan Winbox, serta IP Address dan gateway pada client dibuat statis.
  2. Login Winbox
  3. Lihat gambar dibawah:

244. Klik Queues, pada tab Simple Queues klik tanda [+].

5. Pada kolom Name isikan nama sesuai selera

6. Isikan IP Address PC Client yang hendak di limit pada kolom Target Address.

7. Pada baris Target Download dan Target Upload isikan Max Limit dengan bandwidth yang ingin kisanak berikan pada client tersebut.

8. Klik OK dan selesai!

Bila kisanak hendak menambahkan Simple Queue baru untuk client lain, klik saja Copy, nanti akan muncul window Simple Queue baru dengan setting yang sama. Kisanak hanya perlu mengganti Nama dan IP Address saja dan seterusnya.

Sekelumit perhitungan bandwidth Simple Queue dan Burst Limit.

Kita ambil gampangnya saja. Misal kisanak punya 10 client yang hendak di atur bandwidthnya, bandwidth tersedia 3Mbps. Bila di pukul rata tinggal dibagi saja:

3Mbps : 10 client = Ketemu 0.3 Mbps/client. Atau 300 Kbps/client.

Sepengetahuan saya, browsing dengan bandwidth 300 Kbps itu sengsara banget wkwkwk. Memuat halaman Facebook saja terasa bagai pungguk merindukan bulan, apalagi untuk streaming video. Oleh karena itulah ada fitur Burst Limit. Dengan burst limit, bandwidth akan dinaikkan untuk beberapa saat sesuai dengan pengaturan yang kita berikan. Contohnya seperti dibawah ini:

Max Limit : 584k

Burst Limit : 768k

Burst Threshold : 256k

Burst Time : 40s (detik) –> Bukan waktu burst sesungguhnya

Penjelasannya sebagai berikut:

Saat bandwidth yang digunakan dibawah Burst Threshold, maka bandwidth yang seharusnya di limit di angka 584k akan diberikan ke angka 768k selama x detik.

Burst Time sendiri bukan sebagai patokan berapa lama burst terjadi. Untuk jelasnya silakan gunakan Burst Time Calculator dan ubek Forum Mikrotik Indonesia untuk lebih jelasnya.

Menurut hemat saya, Simple Queue dengan Burst Limit-nya bersifat trial and error. Silakan kisanak lakukan pengaturan sesuai selera sampai ketemu settingan yang tepat.

Keuntungan Simple Queue : Gampang dan cepat

Kerugian Simple Queue : Jatah bandwidth bersifat kaku. Apalagi bila client tidak tersambung semua, ada bandwidth nganggur yang seharusnya bisa digunakan untuk memuaskan pengguna.

CMIIW, dan sampaikan keluh kesah dan caci maki kisanak pada pojok komentar ya!